<!DOCTYPE html>
<!--[if lt IE 7]> <html class="lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="lt-ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Reps: Minority Caucus Berates Buhari Over UNGA Speech - SIGNAL</title>
<link rel="profile" href="http://gmpg.org/xfn/11">

<link rel="pingback" href="http://www.signalng.com/xmlrpc.php">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

<meta name="HandheldFriendly" content="True">
<meta name="apple-touch-fullscreen" content="yes" />
<meta name="MobileOptimized" content="320">
<link rel="pingback" href="http://www.signalng.com/xmlrpc.php">


<!-- This site is optimized with the Yoast SEO plugin v12.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Reps: Minority Caucus Berates Buhari Over UNGA Speech - SIGNAL" />
<meta property="og:description" content="Reps Minority caucus in the House of Representatives yesterday condemned President Muhammadu Buhari over his speech at the 76th United.." />
<meta property="og:url" content="http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/" />
<meta property="og:site_name" content="SIGNAL" />
<meta property="article:tag" content="76th United Nations General Assembly (UNGA)" />
<meta property="article:tag" content="Muhammadu Buhari" />
<meta property="article:tag" content="Ndidu Elumelu" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2021-09-26T07:16:46+00:00" />
<meta property="og:image" content="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="427" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Reps Minority caucus in the House of Representatives yesterday condemned President Muhammadu Buhari over his speech at the 76th United.." />
<meta name="twitter:title" content="Reps: Minority Caucus Berates Buhari Over UNGA Speech - SIGNAL" />
<meta name="twitter:image" content="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.signalng.com/#website","url":"http://www.signalng.com/","name":"SIGNAL","potentialAction":{"@type":"SearchAction","target":"http://www.signalng.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/#primaryimage","url":"http://www.signalng.com/wp-content/uploads/buhari-in-unga-72.jpg","width":640,"height":427},{"@type":"WebPage","@id":"http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/#webpage","url":"http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/","inLanguage":"en-US","name":"Reps: Minority Caucus Berates Buhari Over UNGA Speech - SIGNAL","isPartOf":{"@id":"http://www.signalng.com/#website"},"primaryImageOfPage":{"@id":"http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/#primaryimage"},"datePublished":"2021-09-26T07:16:46+00:00","dateModified":"2021-09-26T07:16:46+00:00","author":{"@id":"http://www.signalng.com/#/schema/person/d2d45dcfa3a4ebd1d2c1d9291895b90e"}},{"@type":["Person"],"@id":"http://www.signalng.com/#/schema/person/d2d45dcfa3a4ebd1d2c1d9291895b90e","name":"Abel Ogwu","image":{"@type":"ImageObject","@id":"http://www.signalng.com/#authorlogo","url":"http://0.gravatar.com/avatar/31e578b3030c77cd9006bb5354870a76?s=96&r=g","caption":"Abel Ogwu"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SIGNAL &raquo; Feed" href="http://www.signalng.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SIGNAL &raquo; Comments Feed" href="http://www.signalng.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SIGNAL &raquo; Reps: Minority Caucus Berates Buhari Over UNGA Speech Comments Feed" href="http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.signalng.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.14"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])?!1:!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55358,56760,9792,65039],[55358,56760,8203,9792,65039])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google-webfonts-css'  href='http://fonts.googleapis.com/css?family=Arvo%3A400%2C700%2C400italic%2C700italic%7CPT+Sans%3A400%2C700%2C400italic%2C700italic%7COpen+Sans%3A400%2C700&#038;ver=5.0.14' type='text/css' media='all' />
<link rel='stylesheet' id='wpgrade-main-style-css'  href='http://www.signalng.com/wp-content/themes/bucket/style.css?ver=1.7.0' type='text/css' media='all' />
<style id='wpgrade-main-style-inline-css' type='text/css'>

                        #text-3 .widget__title { display: none; }
.header--type2 .nav--top-right { display: none; }
.header--type3 .nav--top-right { display: none; }                    

</style>
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.signalng.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.14' type='text/css' media='all' />
<script type='text/javascript' src='http://www.signalng.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.signalng.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.signalng.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.signalng.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.signalng.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.0.14" />
<link rel='shortlink' href='http://www.signalng.com/?p=204625' />
<link rel="alternate" type="application/json+oembed" href="http://www.signalng.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.signalng.com%2Freps-minority-caucus-berates-buhari-over-unga-speech%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.signalng.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.signalng.com%2Freps-minority-caucus-berates-buhari-over-unga-speech%2F&#038;format=xml" />
<link rel='icon' href="http://www.signalng.com/wp-content/uploads/fvn.png" >
<link rel="apple-touch-icon" href="http://www.signalng.com/wp-content/uploads/touch.png" >
<meta name="msapplication-TileColor" content="#f01d4f">
<meta name="msapplication-TileImage" content="http://www.signalng.com/wp-content/uploads/metro.png" >
<script type="text/javascript">
;(function($){
                                            
})(jQuery);
</script>
</head>
<body class="post-template-default single single-post postid-204625 single-format-standard" itemscope itemtype="http://schema.org/WebPage">
    <div class="pace">
        <div class="pace-activity"></div>
    </div>
    <div id="page">
        <nav class="navigation  navigation--mobile  overthrow">
            <h2 class="accessibility">Primary Mobile Navigation</h2>
            <div class="search-form  push-half--top  push--bottom  soft--bottom">
                <form class="form-search" method="get" action="http://www.signalng.com/" role="search">
    <input class="search-query" type="text" name="s" id="s" placeholder="Search..." autocomplete="off" value="" /><!--
    --><button class="btn search-submit" id="searchsubmit"><i class="icon-search"></i></button>
</form>            </div>
            <ul id="menu-mnu_1" class="nav  nav--main"><li id="menu-item-370" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-370"><a href="http://www.signalng.com/">Home</a></li>
<li id="menu-item-471" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-471"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-472" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-472"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/nigeria/">Nigeria</a></li>
	<li id="menu-item-485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-485"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/africa/">Africa</a></li>
	<li id="menu-item-473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-473"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-474"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/nigeria-sports/">Nigeria</a></li>
	<li id="menu-item-484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-484"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/africa-sports/">Africa</a></li>
	<li id="menu-item-475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-475"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/world-sports/">World</a></li>
</ul>
</li>
<li id="menu-item-483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-483"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/investigations/">Investigations</a></li>
<li id="menu-item-477" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-477"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/">Issues</a>
<ul class="sub-menu">
	<li id="menu-item-479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-479"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/business/">Business</a></li>
	<li id="menu-item-480" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-480"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/faith/">Faith</a></li>
	<li id="menu-item-481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-481"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/health/">Health</a></li>
	<li id="menu-item-482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-482"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/others/">Others</a></li>
	<li id="menu-item-478" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-478"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/politics/">Politics</a></li>
</ul>
</li>
<li id="menu-item-486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-486"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/">Techies</a>
<ul class="sub-menu">
	<li id="menu-item-487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-487"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/auto/">Auto</a></li>
	<li id="menu-item-488" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-488"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/gadgets/">Gadgets</a></li>
	<li id="menu-item-489" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-489"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/others-techies/">Others</a></li>
</ul>
</li>
<li id="menu-item-499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-499"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/campus-signal/">Campus Signal</a></li>
<li id="menu-item-490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-490"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/">Life Signal</a>
<ul class="sub-menu">
	<li id="menu-item-492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-492"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/fashion-signal/">Fashion Signal</a></li>
	<li id="menu-item-491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-491"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/events/">Events</a></li>
	<li id="menu-item-494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-494"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/movies/">Movies</a></li>
	<li id="menu-item-495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-495"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/music-life-signal/">Music</a></li>
	<li id="menu-item-496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-496"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/people/">People</a></li>
	<li id="menu-item-497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-497"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/pic-of-the-day/">Pic of the Day</a></li>
	<li id="menu-item-498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-498"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/places/">Places</a></li>
</ul>
</li>
</ul><hr class="separator  separator--mobile-nav" /><ul id="menu-top-menu-left" class="nav  nav--stacked"><li id="nav--top__item-515" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/about/" class="menu-link main-menu-link">About SIGNAL</a></li><li id="nav--top__item-510" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/advertise/" class="menu-link main-menu-link">Advertise</a></li><li id="nav--top__item-509" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/drop/" class="menu-link main-menu-link">Drop a Packet</a></li><li id="nav--top__item-603" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/contact/" class="menu-link main-menu-link">Contact</a></li></ul>        </nav>
        <div class="wrapper">
            <header class="header header--type2">

    <nav class="navigation  navigation--top">

        <div class="container">
            <h2 class="accessibility">Secondary Navigation</h2>
			
            <div class="grid">
                <div class="grid__item one-half">
                    <ul id="menu-top-menu-left-1" class="nav  nav--top  nav--top-left  nav--block"><li id="nav--top__item-515" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/about/" class="menu-link main-menu-link">About SIGNAL</a></li><li id="nav--top__item-510" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/advertise/" class="menu-link main-menu-link">Advertise</a></li><li id="nav--top__item-509" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/drop/" class="menu-link main-menu-link">Drop a Packet</a></li><li id="nav--top__item-603" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.signalng.com/contact/" class="menu-link main-menu-link">Contact</a></li></ul>                </div><!--
             --><div class="grid__item one-half text--right">
                    <ul class="header-bar header-bar--top nav flush--bottom"><!--
				     --><li></li><!--
                     --><li>			<li>
				<a class="social-icon-link" href="https://twitter.com/thesignalng" target="_blank">
					<i class="pixcode  pixcode--icon  icon-e-twitter square"></i>
				</a>
			</li>
					<li>
				<a class="social-icon-link" href="https://www.facebook.com/thesignalng" target="_blank">
					<i class="pixcode  pixcode--icon  icon-e-facebook square"></i>
				</a>
			</li>
					<li>
				<a class="social-icon-link" href="http://www.signalng.com/rss" target="_blank">
					<i class="pixcode  pixcode--icon  icon-e-rss square"></i>
				</a>
			</li>
					<li>
				<a class="social-icon-link" href="http://www.instagram.com/thesignalng" target="_blank">
					<i class="pixcode  pixcode--icon  icon-e-instagram square"></i>
				</a>
			</li>
		</li><!--
                                             --><li><form class="form-search" method="get" action="http://www.signalng.com/" role="search">
    <input class="search-query" type="text" name="s" id="s" placeholder="Search..." autocomplete="off" value="" /><!--
    --><button class="btn search-submit" id="searchsubmit"><i class="icon-search"></i></button>
</form></li><!--
                                         --></ul>
                </div>
            </div>
        </div>

    </nav>

    <div class="container">

        <div class="site-header flexbox">
            <div class="site-header__branding  flexbox__item  one-whole  lap-and-up-three-tenths">
                    <a class="site-logo  site-logo--image    site-logo--image-2x" href="http://www.signalng.com" title="SIGNAL">
                <img src="http://www.signalng.com/wp-content/uploads/signal1x.png" data-logo2x="http://www.signalng.com/wp-content/uploads/signal-logo-2x.png" rel="logo" alt="SIGNAL"/>
    </a>

            </div><!--
            -->			<div class="header-ad  flexbox__item  one-whole  lap-and-up-seven-tenths">
                                                                        </div>
			        </div>

        <div class="site-navigation__trigger js-nav-trigger"><span class="nav-icon"></span></div>                
        
		<hr class="nav-top-separator separator separator--subsection flush--bottom" />
		
        <nav class="navigation  navigation--main  js-navigation--main">
            <h2 class="accessibility">Primary Navigation</h2>
            <div class="nav--main__wrapper  js-sticky">
                <ul id="menu-mnu_1-1" class="nav  nav--main  js-nav--main">
<li id="nav--top__item-370" class="nav__item depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-home hidden"><a href="http://www.signalng.com/" class="menu-link main-menu-link">Home</a></li>
<li id="nav--top__item-471" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item--parent hidden">
<a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/" class="menu-link main-menu-link">News</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><ul class="nav nav--stacked nav--sub-menu sub-menu">
<li id="nav--top__item-472" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/nigeria/" class="menu-link sub-menu-link">Nigeria</a></li>
<li id="nav--top__item-485" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/africa/" class="menu-link sub-menu-link">Africa</a></li>
<li id="nav--top__item-473" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/world/" class="menu-link sub-menu-link">World</a></li>
</ul></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/strike-nard-gives-fg-72-hours-to-pay-withheld-salaries/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/doctors-in-surgery-203x157.jpg" alt="Strike: NARD Gives FG 72 Hours to Pay Withheld Salaries" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Strike: NARD Gives FG 72 Hours to Pay Withheld Salaries</span></h2>
											<div class="article__description">The Nigerian Association of Resident Doctors (NARD) on Saturday gave the Fe..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72-203x157.jpg" alt="Reps: Minority Caucus Berates Buhari Over UNGA Speech" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Reps: Minority Caucus Berates Buhari Over UNGA Speech</span></h2>
											<div class="article__description">Reps Minority caucus in the House of Representatives yesterday condemned Pr..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/76th-unga-amina-mohammed-opposes-talibans-anti-women-policies/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/amina-mohammed-203x157.jpg" alt="76th UNGA: Amina Mohammed Opposes Taliban’s Anti-Women Policies" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">76th UNGA: Amina Mohammed Opposes Taliban’s Anti-Women Policies</span></h2>
											<div class="article__description">Nigeria’s Amina Mohammed, UN’s deputy secretary-general, has opposed the Ta..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/court-jails-ugandan-govt-official-orders-him-to-pay-5-4m/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/court-hammer_thumb1-203x157.jpg" alt="Court Jails Ugandan Govt Official,  Orders Him to Pay $5.4m" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Court Jails Ugandan Govt Official,  Orders Him to Pay $5.4m</span></h2>
											<div class="article__description">A Ugandan anti-corruption court Friday sentenced a government official to 4..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-474" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item--parent hidden">
<a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/" class="menu-link main-menu-link">Sports</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><ul class="nav nav--stacked nav--sub-menu sub-menu">
<li id="nav--top__item-476" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/nigeria-sports/" class="menu-link sub-menu-link">Nigeria</a></li>
<li id="nav--top__item-484" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/africa-sports/" class="menu-link sub-menu-link">Africa</a></li>
<li id="nav--top__item-475" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/sports/world-sports/" class="menu-link sub-menu-link">World</a></li>
</ul></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/oleksandr-usyk-defeats-anthony-joshua-becomes-heavyweight-champion/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/1342507936.0-203x157.jpg" alt="Oleksandr Usyk Defeats Anthony Joshua, Becomes Heavyweight Champion" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Oleksandr Usyk Defeats Anthony Joshua, Becomes Heavyweight Champion</span></h2>
											<div class="article__description">Anthony Joshua, fresh from being dethroned as world boxing heavyweight cham..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/arsenal-win-again-as-liverpool-top-premier-league/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/martin-odegaard_4f3ogwg5mya91hfmr8wg6p92a-203x157.jpg" alt="Arsenal Win Again as Liverpool Top Premier League" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Arsenal Win Again as Liverpool Top Premier League</span></h2>
											<div class="article__description">Martin Odegaard scored his first goal since his permanent switch to Arsenal..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/2022-qualifiers-ronaldo-breaks-world-record-scores-brace-in-portugal-win/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/ronaldo1-203x157.jpg" alt="2022 Qualifiers: Ronaldo Breaks World Record, Scores Brace in Portugal Win" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">2022 Qualifiers: Ronaldo Breaks World Record, Scores Brace in Portugal Win</span></h2>
											<div class="article__description">Cristiano Ronaldo claimed a scoring world record on Wednesday when his late..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/manchester-city-thrash-arsenal-5-0/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/aqtokkgbrqgu_nikxeey7xbom_1440x960-203x157.jpg" alt="Manchester City Thrash Arsenal 5-0" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Manchester City Thrash Arsenal 5-0</span></h2>
											<div class="article__description">Manchester City rubbed salt into Arsenal wounds with a 5-0 thrashing on Sat..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-483" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/investigations/" class="menu-link main-menu-link">Investigations</a></li>
<li id="nav--top__item-477" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item--parent hidden">
<a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/" class="menu-link main-menu-link">Issues</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><ul class="nav nav--stacked nav--sub-menu sub-menu">
<li id="nav--top__item-479" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/business/" class="menu-link sub-menu-link">Business</a></li>
<li id="nav--top__item-480" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/faith/" class="menu-link sub-menu-link">Faith</a></li>
<li id="nav--top__item-481" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/health/" class="menu-link sub-menu-link">Health</a></li>
<li id="nav--top__item-482" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/others/" class="menu-link sub-menu-link">Others</a></li>
<li id="nav--top__item-478" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/politics/" class="menu-link sub-menu-link">Politics</a></li>
</ul></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/itel-donates-libraries-educational-materials-to-three-schools-in-lagos-with-nengi/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/screenshot_20210926-104723_1-203x157.jpg" alt="itel Donates Libraries, Educational Materials to Three Schools in Lagos With Nengi" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">itel Donates Libraries, Educational Materials to Three Schools in Lagos With Nengi</span></h2>
											<div class="article__description">itel Donates Libraries, Educational Materials With Nengi Through Love Alway..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/itel-opens-itel-home-store-in-lagos-a-walk-in-store-for-all-itel-products/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/jpg-1-203x157.jpeg" alt="itel Opens itel Home Store in Lagos, A Walk-in Store for all itel Products" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">itel Opens itel Home Store in Lagos, A Walk-in Store for all itel Products</span></h2>
											<div class="article__description">‘Welcome to the itel Home Store Opening Event!’ This statement was met with..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/crystal-hills-fze-launches-wipes-and-hand-sanitizer/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/img-20210629-wa0015-203x157.jpg" alt="Crystal Hills Fze Launches Wipes and Hand Sanitizer" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Crystal Hills Fze Launches Wipes and Hand Sanitizer</span></h2>
											<div class="article__description">In solving the challenges of hygiene that comes with the pressure of time a..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/pan-nigeria-higer-bus-bags-best-new-auto-entrant-commercial-award/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/pan-678x381-203x157.jpg" alt="PAN Nigeria Higer Bus bags Best New Auto Entrant Commercial Award" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">PAN Nigeria Higer Bus bags Best New Auto Entrant Commercial Award</span></h2>
											<div class="article__description">PAN Nigeria Limited has been awarded the best new auto entrant in the comme..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-486" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item--parent hidden">
<a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/" class="menu-link main-menu-link">Techies</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><ul class="nav nav--stacked nav--sub-menu sub-menu">
<li id="nav--top__item-487" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/auto/" class="menu-link sub-menu-link">Auto</a></li>
<li id="nav--top__item-488" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/gadgets/" class="menu-link sub-menu-link">Gadgets</a></li>
<li id="nav--top__item-489" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/techies/others-techies/" class="menu-link sub-menu-link">Others</a></li>
</ul></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/tik-tok-owner-to-sue-the-u-s-for-unfair-treatment/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/tiktok-203x157.jpg" alt="Tik Tok Owner to Sue the U.S. for Unfair Treatment" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Tik Tok Owner to Sue the U.S. for Unfair Treatment</span></h2>
											<div class="article__description">Beijing, Aug 7 (Prensa Latina) The Chinese internet company ByteDance repor..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/twitter-faces-250m-fine-for-misusing-phone-numbers-and-email-addresses/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/skynews-twitter-logo_4404833-203x157.jpg" alt="Twitter Faces $250m Fine for Misusing Phone Numbers and Email Addresses" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Twitter Faces $250m Fine for Misusing Phone Numbers and Email Addresses</span></h2>
											<div class="article__description">Twitter could be facing a fine of up to $250m (£190m) for misusing users..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/trump-vows-to-ban-tiktok-app-in-the-u-s-today/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/trump-live-tweeting-1-203x157.jpg" alt="Trump Vows to Ban TikTok App in the U.S. Today" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Trump Vows to Ban TikTok App in the U.S. Today</span></h2>
											<div class="article__description">President Trump told reporters late Friday that he plans to ban the social ..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://www.signalng.com/how-rxdelivered-revolutionized-access-to-drugs-during-covid-19-lockdown-ogunoiki/"><div class="article__thumb" style="">
<img data-src="http://www.signalng.com/wp-content/uploads/akindele-ogunoiki-signal-203x157.jpg" alt="INTERVIEW | How RxAll Inc Revolutionized Access to Drugs During COVID-19 Lockdown – Ogunoiki" width="203" height="157" class=" lazy ">
</div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">INTERVIEW | How RxAll Inc Revolutionized Access to Drugs During COVID-19 Lockdown – Ogunoiki</span></h2>
											<div class="article__description">Akindele Ogunoiki trained as a pharmacist at Obafemi Awolowo University, Il..</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-499" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/campus-signal/" class="menu-link main-menu-link">Campus Signal</a></li>
<li id="nav--top__item-490" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item--parent hidden nav__item--relative">
<a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/" class="menu-link main-menu-link">Life Signal</a><ul class="nav nav--stacked nav--sub-menu sub-menu">
<li id="nav--top__item-492" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/fashion-signal/" class="menu-link sub-menu-link">Fashion Signal</a></li>
<li id="nav--top__item-491" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/events/" class="menu-link sub-menu-link">Events</a></li>
<li id="nav--top__item-494" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/movies/" class="menu-link sub-menu-link">Movies</a></li>
<li id="nav--top__item-495" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/music-life-signal/" class="menu-link sub-menu-link">Music</a></li>
<li id="nav--top__item-496" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/people/" class="menu-link sub-menu-link">People</a></li>
<li id="nav--top__item-497" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/pic-of-the-day/" class="menu-link sub-menu-link">Pic of the Day</a></li>
<li id="nav--top__item-498" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/life-signal/places/" class="menu-link sub-menu-link">Places</a></li>
</ul>
</li>
</ul>            </div>
        </nav>

    </div>

</header><!-- .header -->
    <div class="container container--main" itemprop="mainEntity" itemscope itemtype="http://schema.org/BlogPosting">

    <div class="grid">

    
    <div class="grid__item  float--left  two-thirds  palm-one-whole  article__featured-image" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
        <meta itemprop="url" content="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72.jpg"/>
        <meta itemprop="width" content="640"/>
        <meta itemprop="height" content="427"/>
        <div class="image-wrap" style="padding-top: 66.71875%">
	                        <img class="riloadr-single" data-src-big="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72.jpg" data-src-small="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72-335x224.jpg" alt="Buhari-in-UNGA-72" />
			        </div>
    </div><!-- .article__featured-image -->


    <article class="post-article  js-post-gallery  grid__item  main  float--left  lap-and-up-two-thirds">
    	<h1 class="article__title  article__title--single" itemprop="name headline">Reps: Minority Caucus Berates Buhari Over UNGA Speech</h1>

<div class="article__title__meta">
	<meta itemprop="datePublished" content="2021-09-26T08:16:46+00:00" />
    
			<div class="article__author-name" itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="http://www.signalng.com/author/abelogwu/" title="Posts by Abel Ogwu" itemprop="sameAs">Abel Ogwu</a></span></div>		<time class="article__time" datetime="2021-09-26T08:16:46+00:00"> on September 26, 2021 at 8:16 am</time>
	</div><!-- .article__title__meta -->

    <p style="text-align: justify;">Reps Minority caucus in the House of Representatives yesterday condemned President Muhammadu Buhari over his speech at the 76th United Nations General Assembly (UNGA) where he listed the gains made by his administration in various sectors of the economy overtime.</p>
<p style="text-align: justify;">The caucus said it was in complete disagreement with the “ugly reality of the failures of his administration, as well as the economic, security and social ruins that have confronted the nation under his watch.”</p>
<p style="text-align: justify;">A statement made by the caucus’ leader, Ndidu Elumelu, described the president’s speech as a great disservice to the nation by not presenting the true picture of affairs in the country.</p>
<p style="text-align: justify;">“The human rights violations, corruption and incompetence in his administration; the excruciating hardship, escalated insecurity, national divisiveness and infrastructural decay under his watch, thereby blocking avenues for desired intervention in our various ailing sectors” are some of the issues the caucus is worried about, the statement read.</p>
<p style="text-align: justify;">It added: “The minority caucus was alarmed by President Buhari’s report to UNGA that terrorists have been so weakened in Nigeria that they are now preying on soft targets, when in reality, insurgents have become so emboldened under his watch, that they are now attacking military formations, kidnapping and killing our gallant officers while overrunning communities and murdering our citizens without restrain.”</p>
<p style="text-align: justify;">As representatives of the people, Elumelu said the caucus was depressed that the President’s speech did not reflect on the kidnapping and killing of students and school children in Nigeria.</p>
<p style="text-align: justify;">He regretted that the speech did not reflect on the closure of schools and crippling of education in many parts of the country where normal life has been destroyed by terrorists, neither did it show any empathy towards the victims of terrorism attacks.</p>
<p style="text-align: justify;">According to the lawmaker, the caucus was shocked by the president’s speech that his administration “built” isolation centres and emergency hospital wards, “all over the country in record time” in the fight against COVID-19; a claim in conflict with the infrastructural reality in the country.</p>
<p style="text-align: justify;">Besides, the caucus noted that the speech did not portray any decisive roadmap towards economic recovery and food security with no personal commitment to end corruption in his administration.</p>
<p style="text-align: justify;">
<p style="text-align: justify;">____</p>
<p style="text-align: justify;"><em>Follow us on Twitter at </em><a href="https://twitter.com/thesignalng"><em>@thesignalng</em></a></p>
<p style="text-align: justify;"><em>Copyright 2021 SIGNAL. Permission to use portions of this article is granted provided appropriate credits are given to </em> <a href="http://www.signalng.com/"><em>www.signalng.com</em></a><em> and other relevant sources.</em></p>

    <div class="grid"><!--
                        --></div>

        
        <div class="article__meta  article--single__meta">
                            <div class="btn-list">
                    <div class="btn  btn--small  btn--secondary">Categories</div>
                    <a class="btn  btn--small  btn--tertiary" href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/" title="View all posts in News">News</a><a class="btn  btn--small  btn--tertiary" href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/nigeria/" title="View all posts in Nigeria">Nigeria</a><a class="btn  btn--small  btn--tertiary" href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/pictures/" title="View all posts in Pictures">Pictures</a>                </div>
                            <div class="btn-list">
                    <div class="btn  btn--small  btn--secondary">Tagged</div>
                    <a class="btn  btn--small  btn--tertiary" href="http://www.signalng.com/tag/76th-united-nations-general-assembly-unga/" title="View all posts tagged 76th United Nations General Assembly (UNGA)">76th United Nations General Assembly (UNGA)</a><a class="btn  btn--small  btn--tertiary" href="http://www.signalng.com/tag/muhammadu-buhari/" title="View all posts tagged Muhammadu Buhari">Muhammadu Buhari</a><a class="btn  btn--small  btn--tertiary" href="http://www.signalng.com/tag/ndidu-elumelu/" title="View all posts tagged Ndidu Elumelu">Ndidu Elumelu</a>                </div>
                    </div>
                
<aside class="author" itemscope itemtype="http://schema.org/Person">
	<div class="author__avatar">
		<img src="http://0.gravatar.com/avatar/31e578b3030c77cd9006bb5354870a76?s=80&#038;r=g" itemprop="image" alt="avatar" />	</div>
	<div class="author__text">
		<div class="author__title">
			<h3 class="accessibility">Author</h3>
			<div class="hN">
				<span itemprop="name"><a href="http://www.signalng.com/author/abelogwu/" title="Posts by Abel Ogwu">Abel Ogwu</a></span>
			</div>
		</div>
		<p class="author__bio" itemprop="description"></p>
		<ul class="author__social-links">
							<li class="author__social-links__list-item">
					<a class="author__social-link" href="http://www.signalng.com" target="_blank">Website</a>
				</li>
														</ul>
	</div>
</aside>
 <hr class="separator  separator--subsection">
            <nav class="post-nav  grid"><!--
                                        --><div class="post-nav-link  post-nav-link--prev  grid__item  one-whole  lap-and-up-one-half">
                    <a href="http://www.signalng.com/oleksandr-usyk-defeats-anthony-joshua-becomes-heavyweight-champion/">
                                <span class="post-nav-link__label">
                                    Previous Article                                </span>
                                <span class="post-nav-link__title">
                                    <h3 class="hN">Oleksandr Usyk Defeats Anthony Joshua, Becomes Heavyweight Champion</h3>
                                </span>
                    </a>
                </div><!--
                                     --><div class="divider--pointer"></div><!--
                                     --><div class="post-nav-link  post-nav-link--next  grid__item  one-whole  lap-and-up-one-half">
                    <a href="http://www.signalng.com/itel-donates-libraries-educational-materials-to-three-schools-in-lagos-with-nengi/">
                                <span class="post-nav-link__label">
                                    Next Article                                </span>
                                <span class="post-nav-link__title">
                                    <h3 class="hN">itel Donates Libraries, Educational Materials to Three Schools in Lagos With Nengi</h3>
                                </span>
                    </a>
                </div><!--
                                    --></nav>

        
        <hr class="separator  separator--section">

        

    <div id="comments" class="comments-area">
        <div class="comments-area-title">
            <h4 class="hN">
                There are no comments            </h4>
            <a class="comments_add-comment" href="#reply-title">Add yours</a>        </div>

        
                
    </div><!-- #comments .comments-area -->
    	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/reps-minority-caucus-berates-buhari-over-unga-speech/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.signalng.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment"><label for="comment" class="show-on-ie8">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true" placeholder="Message"></textarea></p><p class="comment-form-author"><label for="author" class="show-on-ie8">Name</label><input id="author" name="author" value="" type="text" placeholder="Name..." size="30"  aria-required='true' /></p><!--
--><p class="comment-form-email"><label for="name" class="show-on-ie8">Email</label><input id="email" name="email" value="" size="30" type="text" placeholder="Email..."  aria-required='true' /></p><!--
--><p class="comment-form-url"><label for="url" class="show-on-ie8">Url</label><input id="url" name="url" value="" size="30" placeholder="Website..." type="text"></p>
<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Send" /> <input type='hidden' name='comment_post_ID' value='204625' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="99e90c8699" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="107"/></p>			</form>
			</div><!-- #respond -->
	    </article><!--

                 --><div class="grid__item  one-third  palm-one-whole  sidebar">
        <div id="text-5" class="widget  widget--main widget_text">			<div class="textwidget"><p><img src="http://www.signalng.com/wp-content/uploads/ad-sign.png"></p>
</div>
		</div><div id="wpgrade_social_links-3" class="widget  widget--main widget_wpgrade_social_links">			<div class="widget__title  widget--sidebar__title"><h2 class="hN">Stay Connected</h2></div>			<div class="btn-list">
										<a href="https://twitter.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-twitter square medium"></i>
						</a>
											<a href="https://www.facebook.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-facebook square medium"></i>
						</a>
											<a href="http://www.signalng.com/rss" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-rss square medium"></i>
						</a>
											<a href="http://www.pinterest.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-pinterest square medium"></i>
						</a>
											<a href="http://www.instagram.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-instagram square medium"></i>
						</a>
											<a href="http://www.youtube.com/user/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-youtube square medium"></i>
						</a>
								</div>
		</div><div id="wpgrade_posts_slider_widget-2" class="widget  widget--main widget_wpgrade_posts_slider_widget"><div class="widget__title  widget--sidebar__title"><h2 class="hN">TRENDING PACKETS</h2></div>			<div class="pixslider  js-pixslider" data-autoheight data-arrows>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://www.signalng.com/wp-content/uploads/doctors-in-surgery-335x256.jpg" alt="Strike: NARD Gives FG 72 Hours to Pay Withheld Salaries" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://www.signalng.com/strike-nard-gives-fg-72-hours-to-pay-withheld-salaries/">Strike: NARD Gives FG 72 Hours to Pay Withheld Salaries</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/" title="View all posts in News">News</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 26 Sep</li>
																		<li class="xpost_comments"><i class="icon-comment"></i>  0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://www.signalng.com/wp-content/uploads/screenshot_20210926-104723_1-335x256.jpg" alt="itel Donates Libraries, Educational Materials to Three Schools in Lagos With Nengi" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://www.signalng.com/itel-donates-libraries-educational-materials-to-three-schools-in-lagos-with-nengi/">itel Donates Libraries, Educational Materials to Three Schools in Lagos With Nengi</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/issues/business/" title="View all posts in Business">Business</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 26 Sep</li>
																		<li class="xpost_comments"><i class="icon-comment"></i>  0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://www.signalng.com/wp-content/uploads/buhari-in-unga-72-335x256.jpg" alt="Reps: Minority Caucus Berates Buhari Over UNGA Speech" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://www.signalng.com/reps-minority-caucus-berates-buhari-over-unga-speech/">Reps: Minority Caucus Berates Buhari Over UNGA Speech</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://www.signalng.com/http:/www.signalng.com/topics/uncategorized/news/" title="View all posts in News">News</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 26 Sep</li>
																		<li class="xpost_comments"><i class="icon-comment"></i>  0</li>
																	</ul>
							</div>
						</div>
					</div>
							</div>
		</div><div id="wpgrade_twitter_widget-2" class="widget  widget--main widget_wpgrade_twitter_widget"><div class="widget__title  widget--sidebar__title"><h2 class="hN">BEACON</h2></div><div class="wp-slider widget-content">Twitter said: "Invalid or expired token."</div></div><div id="text-4" class="widget  widget--main widget_text">			<div class="textwidget"><p><img src="http://www.signalng.com/wp-content/uploads/ad-sign.png"></p>
</div>
		</div>    </div>
    
    </div>
    </div>

   
    </div><!-- .wrapper --> 
    
        <div class="site__stats">
        <div class="container">
        
                        <ul class="stat-group nav nav--banner">
									<li>
													<a href="http://www.signalng.com/2021/09/" class="stat">
													<dd class="stat__value" style="height:51.6042780749%;">193</dd>
							<dt class="stat__title">Sep</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/08/" class="stat">
													<dd class="stat__value" style="height:61.4973262032%;">230</dd>
							<dt class="stat__title">Aug</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/07/" class="stat">
													<dd class="stat__value" style="height:84.7593582888%;">317</dd>
							<dt class="stat__title">Jul</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/06/" class="stat">
													<dd class="stat__value" style="height:77.0053475936%;">288</dd>
							<dt class="stat__title">Jun</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/05/" class="stat">
													<dd class="stat__value" style="height:71.1229946524%;">266</dd>
							<dt class="stat__title">May</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/04/" class="stat">
													<dd class="stat__value" style="height:60.9625668449%;">228</dd>
							<dt class="stat__title">Apr</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/03/" class="stat">
													<dd class="stat__value" style="height:87.1657754011%;">326</dd>
							<dt class="stat__title">Mar</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/02/" class="stat">
													<dd class="stat__value" style="height:91.4438502674%;">342</dd>
							<dt class="stat__title">Feb</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2021/01/" class="stat">
													<dd class="stat__value" style="height:91.4438502674%;">342</dd>
							<dt class="stat__title">Jan</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2020/12/" class="stat">
													<dd class="stat__value" style="height:100%;">374</dd>
							<dt class="stat__title">Dec</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2020/11/" class="stat">
													<dd class="stat__value" style="height:91.7112299465%;">343</dd>
							<dt class="stat__title">Nov</dt>
						
                                                    </a>
                                                                  
					</li>
									<li>
													<a href="http://www.signalng.com/2020/10/" class="stat">
													<dd class="stat__value" style="height:98.3957219251%;">368</dd>
							<dt class="stat__title">Oct</dt>
						
                                                    </a>
                                                                  
					</li>
				            </ul>
                        <div class="back-to-top"><a href="#page">Back to Top</a></div>
                    </div>
    </div>
        
    <footer class="site__footer">
        
        <h2 class="accessibility"></h2>
		
    	
            <div class="footer__sidebar">

                <div class="container">
                    
                    <div class="footer__widget-area  grid"><!--
                                                 --><div class="grid__item one-third  palm-one-whole">
                                <div id="text-2" class="widget_text  widget  widget-area__first  widget--footer">			<div class="textwidget"><p>SIGNAL is an online newspaper designed to inform, educate and entertain a global audience of readers with distinctively radical and inspirational media content.</p>
</div>
		</div>                            </div><!--
                                                                            --><div class="grid__item one-third  palm-one-whole">
                                <div id="nav_menu-2" class="widget_nav_menu  widget  widget-area__first  widget--footer"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-519"><a href="http://www.signalng.com/best-practices-at-signal/">Best Practices at SIGNAL</a></li>
<li id="menu-item-520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-520"><a href="http://www.signalng.com/editorial-policies/">Editorial Policies</a></li>
<li id="menu-item-517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-517"><a href="http://www.signalng.com/drop/">Drop a Packet</a></li>
<li id="menu-item-518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-518"><a href="http://www.signalng.com/advertise/">Advertise</a></li>
</ul></div></div>                            </div><!--
                                                                            --><div class="grid__item one-third  palm-one-whole">
                                <div id="wpgrade_social_links-2" class="widget_wpgrade_social_links  widget  widget-area__first  widget--footer">						<div class="btn-list">
										<a href="https://twitter.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-twitter square medium"></i>
						</a>
											<a href="https://www.facebook.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-facebook square medium"></i>
						</a>
											<a href="http://www.signalng.com/rss" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-rss square medium"></i>
						</a>
											<a href="http://www.pinterest.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-pinterest square medium"></i>
						</a>
											<a href="http://www.instagram.com/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-instagram square medium"></i>
						</a>
											<a href="http://www.youtube.com/user/thesignalng" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-youtube square medium"></i>
						</a>
								</div>
		</div>                            </div><!--
                                         --></div>
                    
                    <div class="footer__widget-area  grid"><!--

                        
                                                
                 --></div>

                </div>

            </div>

    			
        <div class="footer__copyright">
            <div class="container">
                <div class="flexbox">
                    <div class="footer-copyright flexbox__item">Copyright © 2015 SIGNAL | All rights reserved.</div>
                    <div class="footer-menu flexbox__item "></div>
                </div>
            </div>
        </div>

    </footer><!-- .site__footer -->
    
    </div><!-- #page -->
<script type='text/javascript' src='http://www.signalng.com/wp-content/themes/bucket/theme-content/js/plugins.min.js?ver=1.7.0'></script>
<script type='text/javascript' src='http://www.signalng.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://pxgcdn.com/js/rs/9.5.7/index.js?ver=5.0.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxurl = "http:\/\/www.signalng.com\/wp-admin\/admin-ajax.php";
var sharrre_urlCurl = "http:\/\/www.signalng.com\/wp-content\/themes\/bucket\/theme-content\/js\/sharrre.php";
var objectl10n = {"tPrev":"Previous (Left arrow key)","tNext":"Next (Right arrow key)","tCounter":"of"};
var theme_name = "bucket";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.signalng.com/wp-content/themes/bucket/theme-content/js/main.min.js?ver=1.7.0'></script>
<script type='text/javascript' src='//s7.addthis.com/js/300/addthis_widget.js#async=1'></script>
<script type='text/javascript' src='http://www.signalng.com/wp-includes/js/comment-reply.min.js?ver=5.0.14'></script>
<script type='text/javascript' src='http://www.signalng.com/wp-includes/js/wp-embed.min.js?ver=5.0.14'></script>
<script async="async" type='text/javascript' src='http://www.signalng.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
                        <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-68316808-1', 'auto');
  ga('send', 'pageview');

</script>                    
</body>
</html>